Da DMX a ARTNET

Home Forum Luce Pro Da DMX a ARTNET

Questo argomento contiene 9 risposte, ha 3 partecipanti, ed è stato aggiornato da  iz1kbp 1 settimana, 2 giorni fa.

Stai vedendo 10 articoli - dal 1 a 10 (di 10 totali)
  • Autore
    Articoli
  • #79430

    balagancik
    Partecipante

    Un saluto a tutti.
    In rete si trovano una miriade di progetti che basati sull’economico e potente chip ESP8266 permettono di realizzare con molta semplicità un comodo convertitore wifi da ARTNET a DMX. Dopo qualche piccola modifica al firmware sono riuscito a realizzare a far funzionare
    QUESTO. Ne ho realizzato diversi esemplari, li uso sia con Q-Light che con Q-lab e devo dire che funzionano veramente bene.
    In alcune installazioni però, mi sarebbe comodo utilizzare la mia vecchia regia 24 con la sola uscita DMX, pertanto sono alla ricerca di un progetto simile che faccia l’operazione inversa, ovvero convertire il segnale DMX in ARTNET e inviarlo sulla rete WIFI. Non avendolo trovato, vi chiedo se siete a conoscenza di un progetto del genere.
    Grazie e Buon lavoro a tutti.

    #79433

    iz1kbp
    Partecipante

    Ciao,
    Lo stesso problema lo avevo io.Io l’ho risolto in altra maniera. Magari non è il tuo caso ma forse potrebbe essere uno spunto per arrivare al risultato seguendo altre strade.
    In certe situazioni uso un mixer bheringer 24ch per comandare anche le luci di un teatro.
    Dato che questo mixer ha una uscita midi che supporta tutti gli slider, ho fatto mangiare al mio programma i dati midi inviati dal mixer in modo da convertirli in maniera semplice in dati dmx (in pratica il dato midi va da 0 a 127, il dmx da 1 a 255…un semplice rapporto 1:2).
    In questa maniera tutto il traffico DMX è generato dal mio programma,il mixer è collegato al mio pc SOLO con un cavo MIDI.
    Non solo, con il mio programma posso modificare e reindirizzare in maniera molto semplice ed immediata (patch) i dati provenienti dal mixer, che invece ha una programmazioni alle volte un po cervellotica.
    Ripeto,è la mia esperienza, magari non centra nulla, magari puo essere uno spunto per altre soluzioni
    Buon lavoro

    Mario

    #79449
    Andrea
    Andrea
    Partecipante

    Ciao,
    guarda QUI

    #80034

    iz1kbp
    Partecipante

    Ciao Balagancik,
    una cortesia se ti è possibile: sto tribulando da un po di tempo con il progetto che hai realizzato tu con l’8266.All’inizio, leggendo il post non ci avevo fatto caso…oggi l’ho riletto,in cerca di “ispirazione” e ho deciso di vedere a cosa rimandava il tuio link.
    E’ proprio il progetto che sto seguendo…ma per ora con scarso successo.
    Cortesemente mi potresti passare il sorgente che usi in modo che possa verificare sul mio, quali settaggi/righe mi danno tutti i problemi che ho?
    In pratica da monitor sembra ok…ma da router non riesco a vederlo per capire l’idirizzo acquisito ergo…non entro in login.
    In ogni caso, grazie comunque.
    Ciao e buon proseguimento
    Mario

    #80081
    Andrea
    Andrea
    Partecipante

    Da quel che vedo nello sketch l’indirizzo dovrebbe essere 192.168.1.1
    Di solito quello è l’indirizzo dei router quindi ti consiglio di cambiarlo, una volta cambiato dovresti vederlo nella tua wifi e collegarti per settare il tutto.

    #80084

    balagancik
    Partecipante

    Quando accendi il dispositivo per la prima volta, oppure quando esso non trova la rete presso la quale è registrato, si attiva come hot spot wifi. Con il pc ti devi collegare a questo hotspot, poi con il browser punti al gateway e ti porta alla pagina di configurazione. Lì inserisci il nome della rete che usi abitualmente, la password, salvi e riavvii.
    Al riavvio il dispositivo si collega alla rete, ed è pronto a convertire il seganli Artnet che arrivano in rete in dmx.
    Se vuoi accedere alla pagina di monitoraggio dell’ESP puoi cercare l’indirizzo ip mediante ipscan. Attenzione, mentre accedi alla pagina l’output dmx viene interrotto.

    #80103

    iz1kbp
    Partecipante

    Ciao ragazzi e grazie.
    Ok,login effettuato!
    Purtroppo l’accesso come hotspot non l’avevo mai sperimentato e quindi, sostanzialmente mi ero arenato su una porta aperta!!!
    Me ne sono accorto usando un Ipad ,che ha “l’accesso di benvenuto” inserito di default nel browser , mentre in ambiente Microsoft o android, si deve cercare tramite router.
    Va bhe…tutta esperienza.
    Rimane un problema…mandando dati artnet ho un un segnale di uscita abbastanza brutto,pieno di errori con un refresh di 12hz..molto instabile.
    DOmanda il pin di uscuta dall’esp è il D4 oppure il Tx ? sul tx non ho attività, sul D4 ho dei segnali ma sono molto instabili
    Aggiungo…riesci a salvare il cambio di universo? a me non riesce
    Mario

    #80134

    iz1kbp
    Partecipante

    Risolto!! il pin della scheda prototito ,l’uscita del d4,non faceva contatto o almeno non era pulita: segnava 34Khom tra l’uscita del modulo e la fine del filo che andava al max485. Ci manca solo questa!!!
    ora funziona ed il seganale è pulito!!

    resta il problema che se volgio cambiare un settaggio….non so salva, rimane su “pagina non trovata” e poi se vado rileggere…ho i sttaggi di prima.

    Il tuo si comporta differentemente?

    Ciao

    mario

    #80139

    balagancik
    Partecipante

    Prova a mettere l’ESP più vicino al router e non avrai il problema di “Pagina non trovata”.
    Il pin di uscita è il D4.
    Rispetto allo schema sul link ho dovuro invertire i pin DMX+ e DMX- (evidentemente l’autore ha fatto confusione tra vista anteriore e posteriore del connettore)
    Poi ho tribolato diversi giorni perché il dispositivo pur ricevendo correttamente i pacchetti dalla rete non dava alcuna attività sull’uscita DMX. Il problema era sul timing del BREAK.

    Ho risolto aggiungendo la seguente riga al listato dello schetch: “delayMicroseconds (220)”
    Quindi la sezione diventa:

    #ifdef SERIAL_BREAK
          Serial1.begin(56700, SERIAL_8N2);
          Serial1.write(0);
          delayMicroseconds (220);
          Serial1.begin(250000, SERIAL_8N2);
    #80143

    iz1kbp
    Partecipante

    Ciao….risolto!!
    Non ho risposto prima adsl down…..
    Il problema è legato alla libreria esp8266 2.5 che non salva correttamente nella e2prom dell’esp.Installando la versione 2.4 (non beta e neppure 2.4.x) il problema si risolve.
    Per quanto riguarda il serial break, l’autore del del programma ha aggiornato il sorgente qualche giorno fa avendo notato, pure lui, parecchi problemi di timing su schede ESP uguali..ma leggermente differenti
    Comunque…provato il tutto questa sera e direi che funziona bene.Ora sto studiando il modo di trasformarla in Nodo artnet per poterla comandare via artnet.
    Grazie per il supporto e buon proseguimento
    Mario

Stai vedendo 10 articoli - dal 1 a 10 (di 10 totali)

Devi essere loggato per rispondere a questa discussione.

Vai alla barra degli strumenti